Welcome Guest. Please Login or Register  


You are here: Index > Webuzo > Bugs > Topic : Import from cpanel looks for incorrect mysql binary path



Threaded Mode | Print  

 Import from cpanel looks for incorrect mysql binary path (4 Replies, Read 2013 times)
interserver
Group: NOC
Post Group: Newbie
Posts: 19
Status:
Import from cpanel does not import mysql correct if mysql is 5.7.
Errors are:
h: /usr/local/apps/mysql/bin/mysql: No such file or directory
sh: /usr/local/apps/mysql/bin/mysql: No such file or directory
sh: /usr/local/apps/mysql/bin/mysql: No such file or directory
sh: /usr/local/apps/mysql/bin/mysql: No such file or directory



/var/webuzo/webuzo.conf has

WU_DEFAULT_MYSQL=mysql57

/usr/local/apps/mysql/bin/mysql is the location of mysql 5.5, which is extremely old and should be removed from webuzo anyway.


Running

Code

mkdir -p /usr/local/apps/mysql/bin/
ln -s /usr/bin/mysql /usr/local/apps/mysql/bin/mysql


resolves the error and import works fine


IP: --   

Import from cpanel looks for incorrect mysql binary path
wolke
Group: NOC
Post Group: Elite Member
Posts: 344
Status:
Installing mysql 5.7 in Webuzo instead of 5.5 was not an option ?
IP: --   

Import from cpanel looks for incorrect mysql binary path
interserver
Group: NOC
Post Group: Newbie
Posts: 19
Status:
MySQL 5.7 is installed.
Webuzo's import from cpanel is looking for the mysql binary at /usr/local/apps/mysql/bin/mysql which is in mysql 5.5. That is not installed.
IP: --   

Import from cpanel looks for incorrect mysql binary path
wolke
Group: NOC
Post Group: Elite Member
Posts: 344
Status:
I see, my fault. You should report this as a bug. I believe this can be fixed only by softaculous staff.
IP: --   

Import from cpanel looks for incorrect mysql binary path
interserver
Group: NOC
Post Group: Newbie
Posts: 19
Status:
Quote From : wolke May 12, 2020, 2:08 pm
I see, my fault. You should report this as a bug. I believe this can be fixed only by softaculous staff.

Posting here to help others out. I have reported bugs to softaculous in webuzo in tickets, I still see the same bugs :)
IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is July 3, 2020, 9:47 am.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:0.204