Topic : Enable HTTP/2 protocol does not work

Posted By: tegralens on January 24, 2019, 9:46 pm
Every time I enable it my wordpress site doesn't work.  When I check in the panel I see apache is not running and I am not able to start it.  This is a recently built webuzo panel.  Any reason why its not starting apache.

Enable HTTP/2 protocol
Check if you want to enable HTTP/2

Posted By: Dhanya on January 25, 2019, 8:27 am | Post: 1

The reason that Apache 2 is not working with HTTP2 in Webuzo is that currently, the module vendor for HTTP/2 has dropped support for Prefork MPM Apache, thus we won't be able to provide the same.

Once they add the support back we will enable the same in Webuzo as well.

Until then we would suggest that you disable the HTTP/2 module.

Let us know if you need any further information.

Posted By: tegralens on January 25, 2019, 12:08 pm | Post: 2
So why is the option there ?  Why not remove it ?

Any updates on when it may be back ?

Posted By: Dhanya on January 28, 2019, 8:33 am | Post: 3

Sorry for the delayed reply.

We cannot remove the option to "Enable HTTP/2 protocol" since it is supported in Nginx. If you want to use HTTP2 module in your site then you can switch from Apache 2.4 to Nginx web server and enable the option from Nginx settings.

Also we don't have update about when it will be added back. Once they add the module back in Apache 2.4 prefork mpm then we will as well provide it.
Let us know if you need any further information from us. We are happy to help you.

Edited by Dhanya : January 28, 2019, 8:34 am

Powered By AEF 1.0.8 © 2007-2008 Electron Inc.