Welcome Guest. Please Login or Register  


You are here: Index > Webuzo > General Support > Topic : Apache with mod_cloudflare Issue



Threaded Mode | Print  

 Apache with mod_cloudflare Issue, Having issues installing mod via Putty (12 Replies, Read 14458 times)
masonshill
Group: Member
Post Group: Newbie
Posts: 5
Status:
Good Afternoon,

I'm not fully convinced this is a Webuzo issue, but I figured I would ask here in hopes someone has had the same problem and knows of a solution. Today I've been installing mod_cloudflare on several VPS servers. All have gone well except the last one, being my Webuzo server. During installation via Putty I get the following error.

Code
warning: mod_cloudflare-el6-x86_64.latest.rpm: Header V4 DSA/SHA1 Signature, key ID 6e5f9j5g: NOKEY
error: Failed dependencies:
        httpd is needed by mod_cloudflare-1.2.0-1360806316.el6.x86_64



I did an Apache check in Webuzo (installed) and also via Putty and got back:

Code
httpd -v
Server version: Apache/2.2.26 (Unix)
Server built:  Nov  8 2013 16:25:05



Apache 2.2.26, The mod_cloudflare requirements are
Code
mod_cloudflare supports Apache httpd 2.2.x and 2.4.x


Another thing I noticed, when I issue "service httpd start" on the other servers it shows httpd being stopped with a green [OK], and then being started with a green [OK], but that does not appear when I issue the command on my Webuzo server, nothing shows up. All sites that require Apache on the server are working properly.

Any advice, tips or tricks are greatly appreciated. Thanks!
IP: --   

Apache with mod_cloudflare Issue
masonshill
Group: Member
Post Group: Newbie
Posts: 5
Status:
Problem has been solved. For whatever reason it simply wouldn't recognize that httpd was running. I was able to install it via the following method:

For CentOS:
Code
# yum install libtool httpd-devel
# wget https://www.cloudflare.com/static/misc/mod_cloudflare/mod_cloudflare.c
# apxs -a -i -c mod_cloudflare.c


Add the following line within the Webuzo Apache Configuration:
Code
LoadModule cloudflare_module /usr/lib64/httpd/modules/mod_cloudflare.so


Restart Apache.
mod_cloudflare is now working  :xd:
IP: --   

Apache with mod_cloudflare Issue
divij
Group: Member
Post Group: Elite Member
Posts: 290
Status:
Hi,

Webuzo does not use the default httpd.
There might be some conflict since you are using default apache.
IP: --   

Apache with mod_cloudflare Issue
haxcop
Group: Member
Post Group: Newbie
Posts: 10
Status:
Hi Guys,
I see the module is being loaded correctly on the Webuzo apache Service but not on the Apache used for the Virtualhost > my websites...how can i Install this properly for the Apache2.4 that i'm working with?
Start of the Reference
Code
user@XX-LT-118:~$ ssh user-2@webuzo
user-2@webuzo's password:
Last login: Tue Oct 23 08:56:09 2018 from 10.0.1.250
[user-2@localhost ~]$ sudo apxs -a -i -c mod_cloudflare.c
[sudo] password for user-2:
/usr/lib64/apr-1/build/libtool --silent --mode=compile gcc -prefer-pic -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -Wformat-security -fno-strict-aliasing  -DLINUX=2 -D_REENTRANT -D_GNU_SOURCE -pthread -I/usr/include/httpd  -I/usr/include/apr-1  -I/usr/include/apr-1  -c -o mod_cloudflare.lo mod_cloudflare.c && touch mod_cloudflare.slo
mod_cloudflare.c: In function ‘set_cf_default_proxies’:
mod_cloudflare.c:188: warning: initialization from incompatible pointer type
/usr/lib64/apr-1/build/libtool --silent --mode=link gcc -o mod_cloudflare.la  -rpath /usr/lib64/httpd/modules -module -avoid-version    mod_cloudflare.lo
/usr/lib64/httpd/build/instdso.sh SH_LIBTOOL='/usr/lib64/apr-1/build/libtool' mod_cloudflare.la /usr/lib64/httpd/modules
/usr/lib64/apr-1/build/libtool --mode=install cp mod_cloudflare.la /usr/lib64/httpd/modules/
libtool: install: cp .libs/mod_cloudflare.so /usr/lib64/httpd/modules/mod_cloudflare.so
libtool: install: cp .libs/mod_cloudflare.lai /usr/lib64/httpd/modules/mod_cloudflare.la
libtool: install: cp .libs/mod_cloudflare.a /usr/lib64/httpd/modules/mod_cloudflare.a
libtool: install: chmod 644 /usr/lib64/httpd/modules/mod_cloudflare.a
libtool: install: ranlib /usr/lib64/httpd/modules/mod_cloudflare.a
libtool: finish: PATH="/sbin:/bin:/usr/sbin:/usr/bin:/sbin" ldconfig -n /usr/lib64/httpd/modules
----------------------------------------------------------------------
Libraries have been installed in:
  /usr/lib64/httpd/modules

If you ever happen to want to link against installed libraries
in a given directory, LIBDIR, you must either use libtool, and
specify the full pathname of the library, or use the `-LLIBDIR'
flag during linking and do at least one of the following:
  - add LIBDIR to the `LD_LIBRARY_PATH' environment variable
    during execution
  - add LIBDIR to the `LD_RUN_PATH' environment variable
    during linking
  - use the `-Wl,-rpath -Wl,LIBDIR' linker flag
  - have your system administrator add LIBDIR to `/etc/ld.so.conf'

See any operating system documentation about shared libraries for
more information, such as the ld(1) and ld.so(8) manual pages.
----------------------------------------------------------------------
chmod 755 /usr/lib64/httpd/modules/mod_cloudflare.so
[activating module `cloudflare' in /etc/httpd/conf/httpd.conf]

[user-2@localhost ~]$ sudo service httpd restarthttpd: Syntax error on line 128 of /usr/local/apps/apache2/etc/httpd.conf: Cannot load /usr/lib64/httpd/modules/mod_cloudflare.so into server: /usr/lib64/httpd/modules/mod_cloudflare.so: undefined symbol: ap_log_rerror
[user-2@localhost ~]$

IP: --   

Apache with mod_cloudflare Issue
Dhanya
Group: Softaculous Team
Post Group: Newbie
Posts: 35
Status:
Hi,

Please try the following commands:
# yum install httpd-devel
# wget https://www.cloudflare.com/static/misc/mod_cloudflare/mod_cloudflare.c
# apxs -a -i -c mod_cloudflare.c

Once done, restart the Apache2 service and then tr executing httpd -M

You will get the following listed:
cloudflare_module (shared)

Also make sure that you have selected Apache2 as Default Web Server from Default Apps page.

Let us know if you need any further information.
IP: --   

Apache with mod_cloudflare Issue
haxcop
Group: Member
Post Group: Newbie
Posts: 10
Status:
Quote From : Dhanya October 27, 2018, 11:28 am
Hi,

Please try the following commands:
# yum install httpd-devel
# wget https://www.cloudflare.com/static/misc/mod_cloudflare/mod_cloudflare.c
# apxs -a -i -c mod_cloudflare.c

Once done, restart the Apache2 service and then tr executing httpd -M

You will get the following listed:
cloudflare_module (shared)

Also make sure that you have selected Apache2 as Default Web Server from Default Apps page.

Let us know if you need any further information.


I have done these steps before but I still receiving the same error on Centos 6.10

Code
  httpd -M
httpd: Syntax error on line 127 of /usr/local/apps/apache2/etc/httpd.conf: Cannot load /usr/lib64/httpd/modules/mod_cloudflare.so into server: /usr/lib64/httpd/modules/mod_cloudflare.so: undefined symbol: ap_log_rerror
IP: --   

Apache with mod_cloudflare Issue
Dhanya
Group: Softaculous Team
Post Group: Newbie
Posts: 35
Status:
Hi,

If you please open a ticket with Webuzo through the following site url, we can check your issue:
https://www.softaculous.com/support/
IP: --   

Apache with mod_cloudflare Issue
haxcop
Group: Member
Post Group: Newbie
Posts: 10
Status:
Quote From : Dhanya October 29, 2018, 8:08 am
Hi,

If you please open a ticket with Webuzo through the following site url, we can check your issue:
https://www.softaculous.com/support/


Done,
Thanks
IP: --   

Apache with mod_cloudflare Issue
Dhanya
Group: Softaculous Team
Post Group: Newbie
Posts: 35
Status:
Hi,

We have resolved your issue. Please refer your ticket for reply. We have successfully installed by the steps that I had given in my previous reply.

Let us know if you face any issues further. We are happy to help you.
IP: --   

Apache with mod_cloudflare Issue
haxcop
Group: Member
Post Group: Newbie
Posts: 10
Status:
Quote From : Dhanya October 31, 2018, 7:03 am
Hi,

We have resolved your issue. Please refer your ticket for reply. We have successfully installed by the steps that I had given in my previous reply.

Let us know if you face any issues further. We are happy to help you.


HI, not true -_- the mod_cloudflare shows in the internal apache 2.2 of the webuzo service and not in the selected for the hosted websites which is 2.4 - the service now doesn't even start...

I have replied on the Ticket.
IP: --   

Apache with mod_cloudflare Issue
Dhanya
Group: Softaculous Team
Post Group: Newbie
Posts: 35
Status:
Hi,

Please check the ticket for reply.
IP: --   

Apache with mod_cloudflare Issue
haxcop
Group: Member
Post Group: Newbie
Posts: 10
Status:
Quote From : Dhanya October 31, 2018, 11:41 am
Hi,

Please check the ticket for reply.


Hi,
Thanks for your prompt reply Dhanya, It works now - (*-*-*-*-*)
IP: --   

Apache with mod_cloudflare Issue
Dhanya
Group: Softaculous Team
Post Group: Newbie
Posts: 35
Status:
Hi,

We are glad to help you. Let us know if you face any issues further.
IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is December 12, 2018, 11:39 pm.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:2.968