Welcome Guest. Please Login or Register  


You are here: Index > Virtualizor - Virtual Server Control Panel > General Support > Topic : KVM MySQL performance issues



Threaded Mode | Print  

 KVM MySQL performance issues (0 Replies, Read 931 times)
MediaServe
Group: NOC
Post Group: Newbie
Posts: 3
Status:
I've just started using Virtualizor and so far everything is great except for a MySQL performance problem I've discovered.

I have configured several host nodes that use the same exact hardware as our regular hosting servers. Only difference is they have twice the RAM and SSD compared to our other hosting servers.

I'm getting better read/write speeds in a VM on one of the nodes than I am on regular hosting servers, which is expected (SSD vs HDD).

I have only one VM set up on the node, and I have assigned it the same amount of RAM and CPU as a regular hosting server.

MySQL is using the exact same configuration as on a regular hosting server.

Yet I have a complicated query that runs in 0.85 seconds on a shared hosting server with about 100 sites on it, but runs in 5.03 seconds on the VM!

I don't get it. I have io set to native and like I said I'm getting better disk speeds on the VM than on the regular server, so it doesn't seem like it would be a disk IO issue. Same amount of RAM is available too.

I've messed with the io scheduler (default set to deadline, tried cfq and noop on the node as well without much difference in the query speed on the VM).

I can't figure out why the same MySQL configuration would act so differently on the VM?

Edited by MediaServe : August 2, 2018, 4:37 pm
IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is December 17, 2018, 5:17 pm.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:2.922