Welcome Guest. Please Login or Register  


You are here: Index > AMPPS > Bugs > Topic : gd.so in AMPPS 2.2 w/ PHP 5.5 returns Apache error



Threaded Mode | Print  

 gd.so in AMPPS 2.2 w/ PHP 5.5 returns Apache error, gd.so in PHP 5.5 returns an Apache error (7 Replies, Read 25016 times)
niels@ampps
Group: Member
Post Group: Newbie
Posts: 4
Status:
Apache error log

[Fri Nov 22 12:19:59.647315 2013] [cgi:error] [pid 8516] [client ::1:61218] AH01215: dyld: lazy symbol binding failed: Symbol not found: _XpmLibraryVersion, referer: ... localhost/ampps/index.php?ind=php
[Fri Nov 22 12:19:59.647354 2013] [cgi:error] [pid 8516] [client ::1:61218] AH01215:  Referenced from: /Applications/AMPPS/php-5.5/lib/extensions/ext/gd.so, referer: ... localhost/ampps/index.php?ind=php
[Fri Nov 22 12:19:59.647371 2013] [cgi:error] [pid 8516] [client ::1:61218] AH01215:  Expected in: flat namespace, referer: ... localhost/ampps/index.php?ind=php
[Fri Nov 22 12:19:59.647375 2013] [cgi:error] [pid 8516] [client ::1:61218] AH01215: , referer: .. localhost/ampps/index.php?ind=php
[Fri Nov 22 12:19:59.647398 2013] [cgi:error] [pid 8516] [client ::1:61218] AH01215: dyld: Symbol not found: _XpmLibraryVersion, referer: .. localhost/ampps/index.php?ind=php
[Fri Nov 22 12:19:59.647436 2013] [cgi:error] [pid 8516] [client ::1:61218] AH01215:  Referenced from: /Applications/AMPPS/php-5.5/lib/extensions/ext/gd.so, referer: .. localhost/ampps/index.php?ind=php
[Fri Nov 22 12:19:59.647453 2013] [cgi:error] [pid 8516] [client ::1:61218] AH01215:  Expected in: flat namespace, referer: .. localhost/ampps/index.php?ind=php
[Fri Nov 22 12:19:59.647457 2013] [cgi:error] [pid 8516] [client ::1:61218] AH01215: , referer: .. localhost/ampps/index.php?ind=php
[Fri Nov 22 12:19:59.835364 2013] [cgi:error] [pid 8516] [client ::1:61218] End of script output before headers: phpinfo.cgi, referer: .. localhost/ampps/index.php?ind=php
libpng warning: Application built with libpng-1.6.3 but running with 1.5.4

TYPO3 CMS install tool returns:

PHP GD library png support broken
GD is compiled with png support, but calling imagecreatefrompng() fails. Check your environment and fix it, png in GD lib is important for TYPO3 CMS to work properly.

phpinfo.cgi returns:

Internal Server Error w/ above Apache log entry.

I tried re-installing AMPPS. If I turn of gd.so again and restart Apache, phpinfo.cgi can be executed withour errors.

Environment =

OS: Mac OS X 10.9

AMPPS Version: 2.2 w/ PHP 5.5


Edited by Moderator : November 22, 2013, 12:37 pm
IP: --   

gd.so in AMPPS 2.2 w/ PHP 5.5 returns Apache error
tidus
Group: Member
Post Group: Super Member
Posts: 1123
Status:
Hi,

What is the output of :

user $ ls -lha /Applications/AMPPS/extra/lib/libgd.dylib


-----------------------
Follow AMPPS on,
Twitter : https://twitter.com/AMPPS_Stack
Facebook :  http://www.facebook.com/softaculousampps
Google+ : https://plus.google.com/+AmppsStack
IP: --   

gd.so in AMPPS 2.2 w/ PHP 5.5 returns Apache error
niels@ampps
Group: Member
Post Group: Newbie
Posts: 4
Status:
lrwxr-xr-x  1 {user}  admin    13B Nov 18 13:20 /Applications/AMPPS/extra/lib/libgd.dylib -> libgd.3.dylib
IP: --   

gd.so in AMPPS 2.2 w/ PHP 5.5 returns Apache error
tidus
Group: Member
Post Group: Super Member
Posts: 1123
Status:
Hi,

Okay. Try running the following commands:

Code
user $ rm -rf /Applications/AMPPS/extra/lib/libgd.dylib
user $ ln -s /Applications/AMPPS/extra/lib/libgd.2.dylib  /Applications/AMPPS/extra/lib/libgd.dylib
user $ /Applications/AMPPS/php/bin/php-cgi -i
if output of last command has any error revert back the symlink :

Code
user $ rm -rf /Applications/AMPPS/extra/lib/libgd.dylib
user $ ln -s /Applications/AMPPS/extra/lib/libgd.3.dylib  /Applications/AMPPS/extra/lib/libgd.dylib


-----------------------
Follow AMPPS on,
Twitter : https://twitter.com/AMPPS_Stack
Facebook :  http://www.facebook.com/softaculousampps
Google+ : https://plus.google.com/+AmppsStack
IP: --   

gd.so in AMPPS 2.2 w/ PHP 5.5 returns Apache error
niels@ampps
Group: Member
Post Group: Newbie
Posts: 4
Status:
The output of the 3td command gives an error, similar to the one in the Apache log:

dyld: lazy symbol binding failed: Symbol not found: _XpmLibraryVersion
  Referenced from: /Applications/AMPPS/php-5.5/lib/extensions/ext/gd.so
  Expected in: flat namespace

dyld: Symbol not found: _XpmLibraryVersion
  Referenced from: /Applications/AMPPS/php-5.5/lib/extensions/ext/gd.so
  Expected in: flat namespace

Reverting back to the symlink did not solve the issue. Calling phpinfo() gives the Internal Server Error. If I use PHP 5.4 everything seems to be fine. The TYPO3 CMS application uses gdlib fine then. Only in PHP 5.5 this happens.
IP: --   

gd.so in AMPPS 2.2 w/ PHP 5.5 returns Apache error
gravy
Group: Member
Post Group: Newbie
Posts: 6
Status:
Did anybody find a solution to this? I am having the same problem.
IP: --   

gd.so in AMPPS 2.2 w/ PHP 5.5 returns Apache error
tidus
Group: Member
Post Group: Super Member
Posts: 1123
Status:
Hi,

This is a Bug. The fix will be available in next version.


-----------------------
Follow AMPPS on,
Twitter : https://twitter.com/AMPPS_Stack
Facebook :  http://www.facebook.com/softaculousampps
Google+ : https://plus.google.com/+AmppsStack
IP: --   

gd.so in AMPPS 2.2 w/ PHP 5.5 returns Apache error
pestka
Group: Member
Post Group: Newbie
Posts: 2
Status:
Quote From : tidus January 25, 2014, 7:57 am
Hi,

This is a Bug. The fix will be available in next version.
Is it fixed now?
If yes what version has this fix?
If no - embarrassment=100%
IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is October 20, 2017, 6:16 pm.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:0.194