Welcome Guest. Please Login or Register  


You are here: Index > AMPPS > General Support > Topic : Ampps is downloading php files instead of displaying them



Threaded Mode | Print  

 Ampps is downloading php files instead of displaying them (0 Replies, Read 1072 times)
kisvukk70
Group: Member
Post Group: Newbie
Posts: 3
Status:
Hi,

I installed ampps 3.9 on linux mint 17 (~ ubuntu 14.04) and use with php 7.1
In the default /usr/local/ampps/www/ directory everything is ok, the php files are work correctly, but under addon domain php files are downloading instead of shown the output.

php -v output:
PHP 7.1.8 (cli) (built: Aug 17 2017 16:56:45) ( NTS )
Copyright (c) 1997-2017 The PHP Group
Zend Engine v3.1.0, Copyright (c) 1998-2017 Zend Technologies
    with the ionCube PHP Loader + ionCube24 v10.4.4, Copyright (c) 2002-2020, by ionCube Ltd.

symlink created and is point to the php-7.1 folder:
sudo ln -s /usr/local/ampps/php-7.1 /usr/local/ampps/php

which php output:
/usr/local/ampps/php/bin/php

etc/enviroment:
/usr/local/ampps/php/bin

httpd.conf content:

LoadModule php7_module /usr/local/ampps/php-7.1/libphp7.so
PHPIniDir "/usr/local/ampps/php-7.1/etc"

        AddType application/x-compress .Z
        AddType application/x-gzip .gz .tgz
    AddType application/x-httpd-php .php
    AddType application/x-tar .tgz
    AddType image/x-icon .ico
    AddType application/vnd.wap.wmlc .wmlc
    AddType application/x-httpd-php .php .phtml .pwml .php5 .php4 .php3 .php2 .inc
    AddType application/x-httpd-php-source .phps

in the /etc/hosts file the domain added:
127.0.0.1    wordpress.test

/usr/local/ampps/apache/conf/extra/ content:

#### wordpress.test VirtualHost ####
           

<VirtualHost 127.0.0.1:80>
<Directory "/mnt/data/spc.wordpress.test">
Options FollowSymLinks Indexes
AllowOverride All
Order deny,allow
allow from All
</Directory>
ServerName wordpress.test
ServerAlias wordpress.test
ScriptAlias /cgi-bin/ "/mnt/data/spc.wordpress.test/cgi-bin/"
DocumentRoot "/mnt/data/spc.wordpress.test"
ErrorLog "/usr/local/ampps/apache/logs/wordpress.test.err"
CustomLog "/usr/local/ampps/apache/logs/wordpress.test.log" combined
</VirtualHost>

####################################

#### wordpress.test SSL Entries ####

<IfModule ssl_module>

<VirtualHost 127.0.0.1:443>
<Directory "/mnt/data/spc.wordpress.test">
Options FollowSymLinks Indexes
AllowOverride All
Order deny,allow
allow from All
</Directory>
ServerName wordpress.test
ServerAlias wordpress.test
ScriptAlias /cgi-bin/ "/mnt/data/spc.wordpress.test/cgi-bin/"
DocumentRoot "/mnt/data/spc.wordpress.test"
SSLEngine on
SSLCipherSuite ALL:!ADH:!EXPORT56:RC4+RSA:+HIGH:+MEDIUM:+LOW:+SSLv2:+EXP:+eNULL
SSLCertificateFile "/usr/local/ampps/apache/conf/ssl_crt/wordpress.test.crt"
SSLCertificateKeyFile "/usr/local/ampps/apache/conf/ssl_key/wordpress.test.key"
SetEnvIf User-Agent ".*MSIE.*" nokeepalive ssl-unclean-shutdown
ErrorLog "/usr/local/ampps/apache/logs/wordpress.test_ssl_error.log"
TransferLog "/usr/local/ampps/apache/logs/wordpress.test_ssl_access.log"
<FilesMatch "\.(cgi|shtml|phtml|php)$">
SSLOptions +StdEnvVars
</FilesMatch>
<Directory "/mnt/data/spc.wordpress.test/cgi-bin/">
SSLOptions +StdEnvVars
</Directory>
BrowserMatch ".*MSIE.*" \
    nokeepalive ssl-unclean-shutdown \
    downgrade-1.0 force-response-1.0
CustomLog "/usr/local/ampps/apache/logs/wordpress.test_ssl_request.log" \
    "%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"
</VirtualHost>
</IfModule>
################################

Thanks for any help!
IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is December 4, 2020, 9:22 am.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:1.026