Welcome Guest. Please Login or Register  


You are here: Index > SitePad Website Builder > General Support > Topic : .HTML tag

1


Threaded Mode | Print  

 .HTML tag, Question (17 Replies, Read 2585 times)
RCH7
Group: Member
Post Group: Newbie
Posts: 3
Status:
Is there a way to use a domain.com/fl110 as opposed to having to use the .html at the end? domain.com/fl110.html  Thanks!
IP: --   

.HTML tag
wired420
Group: Member
Post Group: Newbie
Posts: 12
Status:
Quote From : RCH7 December 28, 2017, 1:41 pm
Is there a way to use a domain.com/fl110 as opposed to having to use the .html at the end? domain.com/fl110.html  Thanks!


Make a file called .htaccess in your web root and add this.

Code

RewriteEngine on
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME}\.html -f
RewriteRule ^(.*)$ $1.html [NC,L]


-----------------------
Owner/Lead Developer @ RootSwitch, LLC
IP: --   

.HTML tag
wired420
Group: Member
Post Group: Newbie
Posts: 12
Status:
Basically what it does is tell the web server when it doesn't find a file, try adding .html to the end of it server side and see if you get a result before going to an error page. Hides it from the user and/or search engines. You'll need to go through and update all your links to follow the same logic for SEO purposes.

-----------------------
Owner/Lead Developer @ RootSwitch, LLC
IP: --   

.HTML tag
RCH7
Group: Member
Post Group: Newbie
Posts: 3
Status:
:squi: I am a REAL NEWBY..    where would I find this "web root" in the site pad menu? 

Make a file called .htaccess in your web root and add this.
IP: --   

.HTML tag
wired420
Group: Member
Post Group: Newbie
Posts: 12
Status:
Quote From : RCH7 December 28, 2017, 2:49 pm
:squi: I am a REAL NEWBY..    where would I find this "web root" in the site pad menu? 

Make a file called .htaccess in your web root and add this.


domain.com/index.html <-- where ever that first index.html is, is your web root. It's the base level of your website to put it in better words.

-----------------------
Owner/Lead Developer @ RootSwitch, LLC
IP: --   

.HTML tag
RCH7
Group: Member
Post Group: Newbie
Posts: 3
Status:
Thank you I finally figured out where to put the code! Works!
IP: --   

.HTML tag
Hostingress
Group: Member
Post Group: Newbie
Posts: 1
Status:

https://www.hostingress.com
.htaccess Will Work.

Thanks.

-----------------------
█ Lowest Host/ Hostingress
█ 24x7 Tech Support https://www.hostingress.com
IP: --   

.HTML tag
aakash_softac
Group: Softaculous Team
Post Group: Elite Member
Posts: 275
Status:
Hi,

As mentioned by @Wired420 the code provided by him should be added in the .htaccess file found in the web accessible directory.

This will hide the given .html extension when the given page is visited by the user.

Glad you issue has been resolved.

-----------------------
Aakash Gupta
SitePad Developer

Follow us for faster updates
Twitter: https://twitter.com/sitepad_editor
Facebook: https://facebook.com/SitePad
IP: --   

.HTML tag
carrelwoot
Group: Member
Post Group: Newbie
Posts: 38
Status:
Why is it not working to my website? Every time that I update my page and post it turns to with .html, help please :(
IP: --   

.HTML tag
wired420
Group: Member
Post Group: Newbie
Posts: 12
Status:
Quote From : carrelwoot March 6, 2018, 8:16 am
Why is it not working to my website? Every time that I update my page and post it turns to with .html, help please :(


If you're using apache you'll need to turn on overrides for that directory.

Code

<Directory /my/web/directory>
AllowOverride all
</Directory>


-----------------------
Owner/Lead Developer @ RootSwitch, LLC
IP: --   

.HTML tag
wired420
Group: Member
Post Group: Newbie
Posts: 12
Status:
Another possibility if using Apache is that you don't have mod_rewrite enabled.

-----------------------
Owner/Lead Developer @ RootSwitch, LLC
IP: --   

.HTML tag
carrelwoot
Group: Member
Post Group: Newbie
Posts: 38
Status:
:cry: It works. I've added this code in my .htaccess :

Options +MultiViews
Options +FollowSymLinks
RewriteEngine on
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME}\.html -f
RewriteRule ^(.*)$ $1.html [NC,L]

and I remove the .html manually to my pages/blog inside file manager in cPanel. :cry:
But, when I publish coz I added something on my page, It keeps on returning to with .html  :cry:

Please help  :squi:  :cry:
IP: --   

.HTML tag
aakash_softac
Group: Softaculous Team
Post Group: Elite Member
Posts: 275
Status:
Quote From : carrelwoot March 8, 2018, 8:11 am

and I remove the .html manually to my pages/blog inside file manager in cPanel. :cry:
But, when I publish coz I added something on my page, It keeps on returning to with .html  :cry:

Please help  :squi:  :cry:


Do you mean the URL on the Menu buttons?

Also when you publish the files are overwritten which is why the .html tag keeps on returning.


-----------------------
Aakash Gupta
SitePad Developer

Follow us for faster updates
Twitter: https://twitter.com/sitepad_editor
Facebook: https://facebook.com/SitePad
IP: --   

.HTML tag
carrelwoot
Group: Member
Post Group: Newbie
Posts: 38
Status:
Yes. so what to do with this problem? :(
IP: --   

.HTML tag
aakash_softac
Group: Softaculous Team
Post Group: Elite Member
Posts: 275
Status:
Hi,

For Menu, firstly you will need to remove the Menu Buttons by deleting each Menu Button and then adding custom link menu. You can recreate the Menu links in SitePad Dashboard > Menu.

Do let us know if you need any other information.

-----------------------
Aakash Gupta
SitePad Developer

Follow us for faster updates
Twitter: https://twitter.com/sitepad_editor
Facebook: https://facebook.com/SitePad
IP: --   

« Previous    Next »

Threaded Mode | Print  

1


Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is October 15, 2018, 10:41 am.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:0.437