Welcome Guest. Please Login or Register  


You are here: Index > AMPPS > Suggestions > Topic : Update default PHP version



Threaded Mode | Print  

 Update default PHP version, PHP 5.3 is old (7 Replies, Read 12584 times)
asegura
Group: Member
Post Group: Newbie
Posts: 12
Status:
AMPPS seems to default to PHP 5.3. That is quite old (released in 2009).

Shouldn't that be increased to 5.4 or 5.5?

Also, as suggested in another post, it would be good to have the installer allow selecting components in order to reduce install size, letting only the PHP version(s) you intend to use.

IP: --   

Update default PHP version
nikhil89
Group: Softaculous Team
Post Group: Elite Member
Posts: 468
Status:
Hi,

You can change the PHP version in AMPPS.

1. First stop the Apache and MySQL service from the AMPPS Control Center.
2. Goto AMPPS Control Center -> PHP -> Change PHP Version.
3. Select the PHP version you wish to use.
4. Start the Apache and MySQL service from the AMPPS Control Center.

Hope this helps.

Please let us know if you need any further information.
IP: --   

Update default PHP version
asegura
Group: Member
Post Group: Newbie
Posts: 12
Status:
Thanks for the answer, but I the suggestion is about increasing the *default active PHP version upon installing AMPPS* (currently 5.3). I know several versions are included and that the active one can be changed.
IP: --   

Update default PHP version
nikhil89
Group: Softaculous Team
Post Group: Elite Member
Posts: 468
Status:
Hi,

Thank you for the suggestion. I have forwarded this request to our developers they shall do the needful soon.

Please let us know if you need any further information. We will be happy to help you.
IP: --   

Update default PHP version
Hydester
Group: Member
Post Group: Newbie
Posts: 5
Status:
I would second the need for automatic upgrade to latest safe versions go php and mysql
IP: --   

Update default PHP version
peopleinside
Group: Member
Post Group: Super Member
Posts: 1262
Status:
Quote From : Hydester November 15, 2015, 1:21 pm
I would second the need for automatic upgrade to latest safe versions go php and mysql


This I think is hard because when you update all settings are loosed if you have customized php :)

Mysql maybe not but when is running the update process all database in mysql stop to works so maybe autoupdate is no possibile at the moment.


-----------------------
PeopleInside  :angel:
Passionate Webuzo User
IP: --   

Update default PHP version
peopleinside
Group: Member
Post Group: Super Member
Posts: 1262
Status:
Quote From : peopleinside December 22, 2015, 10:59 pm
Quote From : Hydester November 15, 2015, 1:21 pm
I would second the need for automatic upgrade to latest safe versions go php and mysql


This I think is hard because when you update all settings are loosed if you have customized php :)

Mysql maybe not but when is running the update process all database in mysql stop to works so maybe autoupdate is no possibile at the moment.


I posted maybe in the wrong topic I AM here in AMPPS sorry I was talking about update php and mysql on Webuzo. For AMPPS I don't know :D


-----------------------
PeopleInside  :angel:
Passionate Webuzo User
IP: --   

Update default PHP version
Rishi_P
Group: AMPPS Team
Post Group: Elite Member
Posts: 317
Status:
Hi,

New AMPPS 3.4 is Released.
AMPPS default PHP is set to PHP 5.5 and PHP 7 added.
IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is December 17, 2018, 1:04 pm.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:0.294