Welcome Guest. Please Login or Register  


You are here: Index > AMPPS > Bugs > Topic : Ampps on Ubuntu



Threaded Mode | Print  

 Ampps on Ubuntu (1 Replies, Read 9492 times)
Krik
Group: Member
Post Group: Newbie
Posts: 7
Status:
Yea basically Ampps is the bug

Ok let see;

1. As most Linux desktops do NOT support a system tray icon there is no way to configure Ampps. As a programmer, I must wonder how any programmer that actually knows what he is doing missed this MAJOR problem.

2. Lxde desktop does have a system tray (the only one I have found so far) and when you click Configuration->AMPPS if you check "Start on Session Startup" and apply, you get a yellow triangle with an exclamation mark next to it. Also, prior to myself manually changing ALL "{$path}" to "/usr/local/ampps/" in the config files, "Python Environment" had the same yellow triangle.

3.
Quote

cd /usr/local/ampps
sudo ./Ampps

and
Quote
sudo /usr/local/ampps/Ampps

Are basically two different programs. The first runs in /usr/local/ampps/ and the second runs in /home/<username>/. Which results to a huge list of errors as it can't find, and thereby place, the config files in the /home/<username>/conf/ folder.

4. Every time I start Ampps I get this error, twice
Quote
QSslSocket: cannot resolve SSLv2_server_method
which apparently has been know for some time. I am hoping I can ignore it.

5. DO NOT install the KDE desktop as the Qt version on it will cause a conflict with the Ampps Qt version.

6. On ALL desktops if you minimize the Ampps Control center it disappears leaving no way to restart the server. Even if you attach it to the Unity launcher you are unable to reopen it.

7 No way to start Ampps other than via the terminal, which is a BIG oxymoron for an application that needs to run in a GUI environment.

8. If Apache and/or MySQL is installed separate from Ampps, you will never get Ampps to start. Maybe not a bug, but a big warning in the wiki is very important at the very minimum.

9. After installing (ie. execute Ampps-3.4-x86_64.run) you must ALSO run install.sh (in the main ampps folder) or you will not be able to get rid of the "Secure Ampps" page.

And as it has been 3 long days, in some kind of nightmare, I need sleep and can't
remember the rest of the bugs so I'll get back to you on the rest.

While I have Ampps running, barely, I can see why in my quest to get it working I found so many posts of people that had given up. Ever issue I ran into, I found several post about it, but always with no answers, and several that ended in the person ditching Ampps. And you can't blame them with this mess.
IP: --   

Ampps on Ubuntu
Krik
Group: Member
Post Group: Newbie
Posts: 7
Status:
Can't edit OP so here goes some more

10. Only on the first runs of "sudo ./Ampps" I got these two errors
Quote

Warning: in_array() expects parameter 2 to be array, null given in /usr/local/ampps/ampps/softaculous/enduser/main/functions.php on line 3185
PHP Warning:  in_array() expects parameter 2 to be array, null given in /usr/local/ampps/ampps/softaculous/enduser/main/functions.php on line 3185

But, I can't scroll to the top of the list, of those errors. It looks like the errors occurred repetitively in the neighbor hood of 30 to 40 times.

11. To install from Ampps-3.4-x86_64.run (the downloaded file) I have to right click the file and under permissions I have to check "Allow executing file as program"

12. To copy any files into the "www" folder I first had to change permisions very carefully, as I needed permission but so does the "ampps" user.

13. Point 9 above if you run install.sh before you load any ampps pages (localhost/ampps, or you own site) you will have to access that "Secure Ampps" page manually before other PC's on your network can see the web page.

Should lastly comment that I did just reinstall (my 7th or 8th time now) and I ran down my very exacting list of how to install. And points 11 and 13 I had not seen them before but that has do to with how I did my install this time, but none the less they are bugs.

Should add that prior to reinstalling I noticed that an "ampps" folder with the ampps.ini had been placed in root, also it had been placed in my users folder (/home/<username>/) as well as the /usr/local/ampps folder. But on this new install I do not see it in any of those folders. Very strange behavior.
IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is May 23, 2018, 1:06 am.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:0.146