Welcome Guest. Please Login or Register  


You are here: Index > AMPPS > General Support > Topic : Install PHP-7.2



Threaded Mode | Print  

 Install PHP-7.2 (1 Replies, Read 2100 times)
swissdoode
Group: Member
Post Group: Newbie
Posts: 5
Status:
I need to install PHP 7.2 on my local machine to run the latest Version of typo3.

I downloaded the package from liip.ch, put it in the AMPPS-folder and manually changed the httpd.conf file from Apache.

But when I restart Apache, it still shows PHP 7.1.8 in the phpinfo as if my self installed PHP-Version wouldn't even exist.

Any ideas?

@Softaculous - when will PHP 7.2 be available as an official install? I think I'm not the only one who needs it ;)
IP: --   

Install PHP-7.2
swissdoode
Group: Member
Post Group: Newbie
Posts: 5
Status:
I'm one step further (sorta).

Now AMPPS tries to start with the new PHP, but then I get an error saying:

Code
httpd: Syntax error on line 159 of /Applications/AMPPS/apache/conf/httpd.conf: Cannot load /usr/local/opt/php/lib/httpd/modules/libphp7.so into server: dlopen(/usr/local/opt/php/lib/httpd/modules/libphp7.so, 10): no suitable image found.  Did find:\n\t/usr/local/opt/php/lib/httpd/modules/libphp7.so: mach-o, but wrong architecture\n\t/usr/local/Cellar/php/7.2.7/lib/httpd/modules/libphp7.so: mach-o, but wrong architecture


Any ideas?
IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is November 17, 2018, 9:32 pm.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 11  |  Page Created In:0.155