Welcome Guest. Please Login or Register  


You are here: Index > AMPPS > General Support > Topic : AMPPS rewrite enable/disable option? please?



Threaded Mode | Print  

 AMPPS rewrite enable/disable option? please?, how would one enable this option in the control panel (11 Replies, Read 21655 times)
webdeveloper
Group: Member
Post Group: Newbie
Posts: 4
Status:
Heres the story, I installed buddy press for my wordpress development site. Need to change the permalink structure so buddypress would work.



Problem is when I do change the permalink structure to %postname under settings in wordpress for buddypress to work. When I visit one of the buddypress pages like for example the activity page on my wordpress. It gives me a 404 not found. Because its not rewriting the URL's.



Do you know how to manually insert the rewrite in apache or enable it on the AMPPS control panel.



*suggestion. if there is not one made, maybe in the future can you implement module
options to enable/disable on the AMPPS control panel just like how the
"wampserver" has theirs.



Thansk.
IP: --   

AMPPS rewrite enable/disable option? please?
tidus
Group: Member
Post Group: Super Member
Posts: 1121
Status:
Hi,

mod_rewrite is enabled by default in AMPPS.

If you want to enable/disable, just open AMPPS Control Center -> Apache Tab -> Configurations and search for line LoadModule rewrite_module modules/mod_rewrite.so and comment/uncomment it by adding/removing hash tag at the beginning of the line. Then restart Apache.

Edited by tidus : December 12, 2012, 11:29 am

-----------------------
Follow AMPPS on,
Twitter : https://twitter.com/AMPPS_Stack
Facebook :  http://www.facebook.com/softaculousampps
Google+ : https://plus.google.com/+AmppsStack
IP: --   

AMPPS rewrite enable/disable option? please?
webdeveloper
Group: Member
Post Group: Newbie
Posts: 4
Status:
Thank you for reply so it looks like rewrite is enabled. I am still getting 404 error when i click on the buddypress pages on my wordpress.

If i go into myPHPadmin and update the permalinks in wordpress options like this manually in mysql
index.php/blog/%postname%/

then the buddypress pages work, but it does not show the activity, group, pages, etc.

Any thoughts on how to make them show up? what do you think the problem would be.
IP: --   

AMPPS rewrite enable/disable option? please?
webdeveloper
Group: Member
Post Group: Newbie
Posts: 4
Status:
I figured it out. This is what I did. Add alias. add domain name and add it under advanced to change host file. When you install buddypress click on the numeric permalink radio button under the installation wizard.
IP: --   

AMPPS rewrite enable/disable option? please?
SystemN
Group: Member
Post Group: Newbie
Posts: 3
Status:
Hello Good People :),

I have this problem, for wordpress all what need for configure mod_rewrite is configure, but I still have a problem.

Please help me, my develop localhost not work but need me so much.

Thank you,
SystemN
IP: --   

AMPPS rewrite enable/disable option? please?
tidus
Group: Member
Post Group: Super Member
Posts: 1121
Status:
Quote From : SystemN December 9, 2012, 10:35 am
Hello Good People :),

I have this problem, for wordpress all what need for configure mod_rewrite is configure, but I still have a problem.

Please help me, my develop localhost not work but need me so much.

Thank you,
SystemN


Hi, Are you trying to configure buddypress?

-----------------------
Follow AMPPS on,
Twitter : https://twitter.com/AMPPS_Stack
Facebook :  http://www.facebook.com/softaculousampps
Google+ : https://plus.google.com/+AmppsStack
IP: --   

AMPPS rewrite enable/disable option? please?
SystemN
Group: Member
Post Group: Newbie
Posts: 3
Status:
Quote From : tidus December 10, 2012, 7:39 am
Quote From : SystemN December 9, 2012, 10:35 am
Hello Good People :),

I have this problem, for wordpress all what need for configure mod_rewrite is configure, but I still have a problem.

Please help me, my develop localhost not work but need me so much.

Thank you,
SystemN


Hi, Are you trying to configure buddypress?


Hello tidus,
Thank you for calling :),

I didn't try "buddypress "even though it's the base "wordpress" or better yet you makeup "wordpress" :D

I need a wordpress, since it develops applications on it through the entire local network.

If you have a solution, tell me, or maybe you know how to set ampps, if not I'll have to get back to wamp.

Thank you,
SystemN
IP: --   

AMPPS rewrite enable/disable option? please?
tidus
Group: Member
Post Group: Super Member
Posts: 1121
Status:
Quote From : SystemN December 10, 2012, 11:14 pm
Quote From : tidus December 10, 2012, 7:39 am
Quote From : SystemN December 9, 2012, 10:35 am
Hello Good People :),

I have this problem, for wordpress all what need for configure mod_rewrite is configure, but I still have a problem.

Please help me, my develop localhost not work but need me so much.

Thank you,
SystemN


Hi, Are you trying to configure buddypress?


Hello tidus,
Thank you for calling :),

I didn't try "buddypress "even though it's the base "wordpress" or better yet you makeup "wordpress" :D

I need a wordpress, since it develops applications on it through the entire local network.

If you have a solution, tell me, or maybe you know how to set ampps, if not I'll have to get back to wamp.

Thank you,
SystemN


Hi,

Here is the video tutorial you can follow to install WordPress:
http://www.youtube.com/watch?v=59RzydcSkI0

If you are facing issues with starting AMPPS, you can open a ticket.
http://www.ampps.com/support

Also refer our FAQs :
http://www.ampps.com/wiki/Category:FAQs

-----------------------
Follow AMPPS on,
Twitter : https://twitter.com/AMPPS_Stack
Facebook :  http://www.facebook.com/softaculousampps
Google+ : https://plus.google.com/+AmppsStack
IP: --   

AMPPS rewrite enable/disable option? please?
SystemN
Group: Member
Post Group: Newbie
Posts: 3
Status:
Quote From : tidus December 11, 2012, 6:45 am
Quote From : SystemN December 10, 2012, 11:14 pm
Quote From : tidus December 10, 2012, 7:39 am
Quote From : SystemN December 9, 2012, 10:35 am
Hello Good People :),

I have this problem, for wordpress all what need for configure mod_rewrite is configure, but I still have a problem.

Please help me, my develop localhost not work but need me so much.

Thank you,
SystemN


Hi, Are you trying to configure buddypress?


Hello tidus,
Thank you for calling :),

I didn't try "buddypress "even though it's the base "wordpress" or better yet you makeup "wordpress" :D

I need a wordpress, since it develops applications on it through the entire local network.

If you have a solution, tell me, or maybe you know how to set ampps, if not I'll have to get back to wamp.

Thank you,
SystemN


Hi,

Here is the video tutorial you can follow to install WordPress:
http://www.youtube.com/watch?v=59RzydcSkI0

If you are facing issues with starting AMPPS, you can open a ticket.
http://www.ampps.com/support

Also refer our FAQs :
http://www.ampps.com/wiki/Category:FAQs


Hello tidus,

I know how to install WordPress, I have reviewed the detailed settings for the Apache, requested by Google, In short, all I zavrio but I have not found a solution for this problem.


I sent a support ticket, I hope you will be able to solve this problem.

Tnank you,
Nenad Mladenovic
IP: --   

AMPPS rewrite enable/disable option? please?
shovan
Group: Member
Post Group: Newbie
Posts: 7
Status:
Hi

I am having same problem. Installing buddypress
IP: --   

AMPPS rewrite enable/disable option? please?
tidus
Group: Member
Post Group: Super Member
Posts: 1121
Status:
Hi,

On which OS are you trying to install WordPress and Buddypress ?

We are able to change the permalinks, please see the attached image.

Is .htaccess created in WordPress Web Directory ?




-----------------------
Follow AMPPS on,
Twitter : https://twitter.com/AMPPS_Stack
Facebook :  http://www.facebook.com/softaculousampps
Google+ : https://plus.google.com/+AmppsStack
IP: --   

AMPPS rewrite enable/disable option? please?
shovan
Group: Member
Post Group: Newbie
Posts: 7
Status:
I am having the same issue. With wordpress. I have checked .htaccess file, every thing seems to be good

Code


# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /opendataplane/
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /opendataplane/index.php [L]
</IfModule>

# END WordPress
IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is September 19, 2019, 11:11 pm.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 10  |  Page Created In:0.395