Welcome Guest. Please Login or Register  


You are here: Index > AMPPS > General Support > Topic : Back ported AMPPS 2.1 to work with Mavericks

1


Threaded Mode | Print  

 Back ported AMPPS 2.1 to work with Mavericks, Apache should work now (16 Replies, Read 22507 times)
tidus
Group: Member
Post Group: Super Member
Posts: 1121
Status:
Hi,

We have back ported AMPPS 2.1 to work with Mac OS X 10.9 Mavericks which can be downloaded from our download page. Now AMPPS Apache can be started directly from the GUI.

For users who are already using AMPPS 2.1, please follow the below instructions.

Before applying patch make sure Ampps is closed.

Run the two commands from Terminal:
Code
mv -f /Applications/AMPPS/Ampps.app/Contents/Frameworks/Security.framework /Applications/AMPPS/Ampps.app/Contents/Frameworks/_Security.framework

ln -s /System/Library/Frameworks/Security.framework /Applications/AMPPS/Ampps.app/Contents/Frameworks/Security.framework


Sorry for the inconvenience caused.

Edited by tidus : November 1, 2013, 6:39 am

-----------------------
Follow AMPPS on,
Twitter : https://twitter.com/AMPPS_Stack
Facebook :  http://www.facebook.com/softaculousampps
Google+ : https://plus.google.com/+AmppsStack
IP: --   

Back ported AMPPS 2.1 to work with Mavericks
afri-can
Group: Member
Post Group: Newbie
Posts: 7
Status:
Sorry for being stupid but if I have ammps 2.1 already installed do I only have to run the two commands in terminal without downloading anything? :squi:
IP: --   

Back ported AMPPS 2.1 to work with Mavericks
tidus
Group: Member
Post Group: Super Member
Posts: 1121
Status:
Quote From : afri-can October 31, 2013, 3:17 pm
Sorry for being stupid but if I have ammps 2.1 already installed do I only have to run the two commands in terminal without downloading anything? :squi:


HI,

Yes

-----------------------
Follow AMPPS on,
Twitter : https://twitter.com/AMPPS_Stack
Facebook :  http://www.facebook.com/softaculousampps
Google+ : https://plus.google.com/+AmppsStack
IP: --   

Back ported AMPPS 2.1 to work with Mavericks
kontramundo
Group: Member
Post Group: Newbie
Posts: 3
Status:
Thank You

greetings from Mexico
IP: --   

Back ported AMPPS 2.1 to work with Mavericks
vikingboy
Group: Member
Post Group: Newbie
Posts: 1
Status:
thank you!
IP: --   

Back ported AMPPS 2.1 to work with Mavericks
schoujar
Group: Member
Post Group: Newbie
Posts: 18
Status:
Thanks!
IP: --   

Back ported AMPPS 2.1 to work with Mavericks
hanxlk
Group: Member
Post Group: Newbie
Posts: 8
Status:
Great! Thanks alot...
IP: --   

Back ported AMPPS 2.1 to work with Mavericks
d1egosan
Group: Member
Post Group: Newbie
Posts: 2
Status:
Hello,

I just installed AMPPS 2.1 for the first time, using Mac OS X 10.9 Mavericks. After I tried running the two commands and opening AMMPS I get a pop up with the following message:

''Ampps.app" can't be opened because it is from an unidentified developer.

Can you please advise? it seems that I'm not running the commands properly. :(

Thanks

IP: --   

Back ported AMPPS 2.1 to work with Mavericks
ketan
Group: Member
Post Group: Working Member
Posts: 241
Status:
Hi,

Please do the following steps,

- Launch System Preferences from the Apple menu,
- Choose “Security & Privacy” and then click the “General” tab, followed by clicking the lock icon in the corner to unlock the settings,
- Look for “Allow applications downloaded from:” and choose “Anywhere”,
- Accept the security warning and allow.

You can now launch any app from any location or developer. Let us know if you still facing the problem.

-----------------------
Follow AMPPS on,
Twitter
Facebook
Google+
IP: --   

Back ported AMPPS 2.1 to work with Mavericks
d1egosan
Group: Member
Post Group: Newbie
Posts: 2
Status:
Hi ketan,

Thank you for your swift response. A new ticket with the same request might has been submitted by mistake after reloading the page, please do ignore it!

Cheers
IP: --   

Back ported AMPPS 2.1 to work with Mavericks
dreamdancer
Group: Member
Post Group: Newbie
Posts: 4
Status:
Hi I just upgraded to Mavericks today. I had MAMP and found it doesn't work with the new system. So I searched and found AMPPS. I have download just today. I cannot get the apache server to start.  I get asked for my admin password, I put it in and the server will not start up.

I even tried the patch, but after the first command I got a terminal message of "permission denied"

Not sure what to do next. This looks like a fantastic program! Just wish Apache would start.
IP: --   

Back ported AMPPS 2.1 to work with Mavericks
ketan
Group: Member
Post Group: Working Member
Posts: 241
Status:
Hi,

Please run the following command in terminal and let us know the output,

sudo /Applications/AMPPS/apache/bin/httpd

-----------------------
Follow AMPPS on,
Twitter
Facebook
Google+
IP: --   

Back ported AMPPS 2.1 to work with Mavericks
manoderecha
Group: Member
Post Group: Newbie
Posts: 1
Status:
:squi: I´ve tried everything and still not able to turn on Apache. Now, when i try to run the line

sudo/Applications(AMPPS/apache/bin/httpd

I get this:

[Fri Nov 08 15:25:46 2013] [warn] NameVirtualHost 127.0.0.1:443 has no VirtualHosts
(48)Address already in use: make_sock: could not bind to address [::]:80
(48)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

Please HELP =(
IP: --   

Back ported AMPPS 2.1 to work with Mavericks
dreamdancer
Group: Member
Post Group: Newbie
Posts: 4
Status:
Quote From : manoderecha November 8, 2013, 3:36 pm
:squi: I´ve tried everything and still not able to turn on Apache. Now, when i try to run the line

sudo/Applications(AMPPS/apache/bin/httpd

I get this:

[Fri Nov 08 15:25:46 2013] [warn] NameVirtualHost 127.0.0.1:443 has no VirtualHosts
(48)Address already in use: make_sock: could not bind to address [::]:80
(48)Address already in use: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

Please HELP =(

I ran that command too and I got this same message
IP: --   

Back ported AMPPS 2.1 to work with Mavericks
dreamdancer
Group: Member
Post Group: Newbie
Posts: 4
Status:
An update to my previous post. The issue was that Apache was already running at localhost, so I followed directions in another post here regarding AMPPS and Mavericks.

In the terminal type this:
sudo apachectl stop

I had completely uninstalled AMPPS first. Then I ran that command. After that I reinstalled AMPPS and Apache started right up using the control center. The address to the server is localhost/ampps instead of just localhost.

So it does work, just turn off the native Apache first.
IP: --   

« Previous    Next »

Threaded Mode | Print  

1


Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is October 24, 2020, 5:19 pm.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 10  |  Page Created In:1.073