Welcome Guest. Please Login or Register  


You are here: Index > AMPPS > General Support > Topic : AMPPS access denied



Threaded Mode | Print  

 AMPPS access denied, AMPPS access denied solution (0 Replies, Read 244 times)
nnasco3k
Group: Member
Post Group: Newbie
Posts: 2
Status:
The best way to have AMPPS access denied fix is manually.
Follow the steps and make sure things are in place accordingly.

1. Download and install AMPPS on C:/ drive.

2. Once installed, open the AMPPS on desktop. If the MySQL button didn't run,

3. Click on MySQL SETTINGS and then, click on CONFIGURATION to open on notepad.

4. Stroll down a little bit and sure PASSWORD, PORT are set to:
(a) password = mysql
(b) port = 3306 (for MySQL button to run, change 3306 to any 4 digit port number of your choice. and wherever you see 3306 should be equally be change to same number of your choice along the settings path when through down).

(C) socket = "{$path}/mysql/mysql.sock"

Please don't include a,b,c in brackets. This are my own of listing the steps for easy to follow. After change port number, save and close the notepad. After saving settings, close and  Restart AMPPS.

5. If MySQL button runs, click on HOME ???? at the top and when it open on the window address as localhost/ampps/
Click on PHPMYADMIN to try to access login section.
When the LOGIN section opens, if access denied or when you are trying to login failed (with username: root and default password: mysql).

6. Goto the root folder of your AMPPS where it's saved in C:\ drive. That's, C:\Ampps
and open the exact folders after it like this:
C:\Ampps\phymyadmin\config.inc.php

Right click and open config.inc.php on text editor and made changes to:

$cfg['servers'][$i]['port'] = 'insert your 4 digit number here';

Remove the 'insert your 4 digit  number here' . This are my own statement. My way of explaining it for easy to understand.
Example:
$cfg['servers'][$i]['port'] = '3390';
Replace it with number of your choice you first use in settings.

7.
$cfg['servers'][$i]['auth_type'] = 'cookie';

Config is changed to cookie. Save it.

8. Goto C:\Ampps\data\my.conf
Open my.conf on test editor and make sure the default password is : mysql

Save it.

9. Goto C:\Ampps\phpMyAdmin\config.sample.inc.php
Click and open config.sample.inc.php on test editor.
$cfg['servers'][$i]['auth_type'] = 'cookie';
????
Make it's set to cookie. Save it.

10. $cfg['servers'][$i]['AllowNoPassword'] = false;
????
It's your choice to decide.
If you want to allow the use of password, set it to:  $cfg['servers'][$i]['AllowNoPassword'] = false;

If you don't want to allow the use of password, set it to:  $cfg['servers'][$i]['AllowNoPassword'] = true;

Save your settings and close it.
After all the steps are followed, restart your AMPPS.
Click on HOME ???? and click on phyMyAdmin to either login with your default username: root and default password: mysql depending on what you choose in [AllowNoPassword] = TRUE or FALSE to have access to  phpMyAdmin index.
Thanks.
IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is September 23, 2020, 4:47 am.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 10  |  Page Created In:0.148