Welcome Guest. Please Login or Register  


You are here: Index > AMPPS > General Support > Topic : Domains not working properly on 3.9, bad apache config created



Threaded Mode | Print  

 Domains not working properly on 3.9, bad apache config created (0 Replies, Read 157 times)
pett
Group: Member
Post Group: Newbie
Posts: 2
Status:
Hi,

I have several problems with domains, managed to resolve some of them, by fixing apache config, but the biggest problem still persists. When I create an addon domain, it doesn't point to desired folder, but always points to www root. Any idea how to fix it?

I checked httpd-vhosts.conf, and VirtualHost is created correctly afaik. I also tried to simplify the hosts config, tried changing DocumentRoot, but it has no effect, domain always points to www root, so the problem must be elsewhere.

vhosts my domain section:
Code
#### trigger.local VirtualHost ####
<VirtualHost 127.0.0.1:80>
<Directory "/Applications/Ampps/www/trigger">
Options FollowSymLinks Indexes
AllowOverride All
Order deny,allow
allow from All
</Directory>
ServerName trigger.local
ServerAlias trigger.local
ScriptAlias /cgi-bin/ "/Applications/Ampps/www/trigger/cgi-bin/"
DocumentRoot "/Applications/Ampps/www/trigger"
ErrorLog "/Applications/Ampps/apache/logs/trigger.local.err"
CustomLog "/Applications/Ampps/apache/logs/trigger.local.log" combined
</VirtualHost>


/etc/hosts:
Code
127.0.0.1    localhost
255.255.255.255    broadcasthost
::1            localhost

127.0.0.1    trigger.local
127.0.0.1    pura.local


httpd-vhosts.conf file attached.

Thank you!

IP: --   

« Previous    Next »

Threaded Mode | Print  



Jump To :


Users viewing this topic
1 guests, 0 users.


All times are GMT. The time now is September 22, 2020, 8:28 am.

  Powered By AEF 1.0.8 © 2007-2008 Electron Inc.Queries: 10  |  Page Created In:0.158